Das deutsche QBasic- und FreeBASIC-Forum Foren-Übersicht Das deutsche QBasic- und FreeBASIC-Forum
Für euch erreichbar unter qb-forum.de, fb-forum.de und freebasic-forum.de!
 
FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen  RegistrierenRegistrieren
ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin
Zur Begleitseite des Forums / Chat / Impressum
Aktueller Forenpartner:

64-Bit Ubuntu + 32-Bit BASIC = @!%#

 
Neues Thema eröffnen   Neue Antwort erstellen    Das deutsche QBasic- und FreeBASIC-Forum Foren-Übersicht -> Linux-spezifische Fragen
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Alexander283



Anmeldungsdatum: 20.01.2011
Beiträge: 15
Wohnort: Darmstadt

BeitragVerfasst am: 16.10.2011, 00:15    Titel: 64-Bit Ubuntu + 32-Bit BASIC = @!%# Antworten mit Zitat

Hallo @ alle grinsen

Ich benutze Ubuntu 11.10 und versuche verzweifelt, FreeBASIC zum laufen zu kriegen. Doch jedes mal, wenn ich versuche, etwas zu kompilieren, kommt DAS:

Code:

alexander@alex-pc:~$ cd Arbeitsfläche
alexander@alex-pc:~/Arbeitsfläche$ fbc -w all "Color.bas"
ld: skipping incompatible /usr/lib/x86_64-linux-gnu/gcc/x86_64-linux-gnu/4.5.2/../../../../../lib32/libncurses.so when searching for -lncurses
ld: skipping incompatible /usr/lib/x86_64-linux-gnu/gcc/x86_64-linux-gnu/4.5.2/libsupc++.a when searching for -lsupc++
ld: cannot find -lsupc++
alexander@alex-pc:~/Arbeitsfläche$


Erklärung: Ich habe einen 64-Bit PC und auch ein 64-Bit Ubuntu, jedoch habe ich noch kein FreeBASIC für 64 Bit gefunden missbilligen

Tja, ich habe auch schon alle Bibliotheken in 32-Bit runtergeladen und so weiter, aber wie man sieht, geht es nicht. mit dem Kopf durch die Mauer wollen

Danke für Hilfe im voraus!
_________________
Programmiersprachen sind dafür da, um den Computer vor dem Programmierer zu schützen
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Jojo
alter Rang


Anmeldungsdatum: 12.02.2005
Beiträge: 9732
Wohnort: Neben der Festplatte

BeitragVerfasst am: 16.10.2011, 00:47    Titel: Antworten mit Zitat

http://www.freebasic.net/forum/viewtopic.php?p=147440
Du musst schon die 32-Bit-Entwicklertools installieren, wenn du mit einem 32-Bit-Compiler arbeiten möchtest.
_________________
» Die Mathematik wurde geschaffen, um Probleme zu lösen, die es nicht gäbe, wenn die Mathematik nicht erschaffen worden wäre.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Alexander283



Anmeldungsdatum: 20.01.2011
Beiträge: 15
Wohnort: Darmstadt

BeitragVerfasst am: 16.10.2011, 01:02    Titel: Antworten mit Zitat

Ok, Danke! lächeln
Die zweite Fehlermeldung (mit dem lsupc++) is weg ...
Die Erste is noch da peinlich

alexander@alex-pc:~/Arbeitsfläche$ fbc -w all "Color.bas"
ld: skipping incompatible /usr/lib/x86_64-linux-gnu/gcc/x86_64-linux-gnu/4.5.2/../../../../../lib32/libncurses.so when searching for -lncurses

Trotzdem vielen Dank!
_________________
Programmiersprachen sind dafür da, um den Computer vor dem Programmierer zu schützen
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
ThePuppetMaster



Anmeldungsdatum: 18.02.2007
Beiträge: 1749
Wohnort: [JN58JR] DeltaLabs.de

BeitragVerfasst am: 16.10.2011, 01:59    Titel: Antworten mit Zitat

http://forum.qbasic.at/viewtopic.php?t=6993


MfG
TPM
_________________
[ WebFBC ][ OPS ][ DeltaLab's ][ ToOFlo ][ BGB-Movie ]
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Alexander283



Anmeldungsdatum: 20.01.2011
Beiträge: 15
Wohnort: Darmstadt

BeitragVerfasst am: 16.10.2011, 10:52    Titel: Antworten mit Zitat

Das versteh ich jetzt nich ... urgs!
Der Compiler gibt zwar immer noch diesen Fehler aus, aber trotztdem kommt hinten ne kompilierte Datei raus ?! verwundert

Egal, Hilfe ist jetzt, , ich sag ma optional Hammer

VIELEN DANK Yahooo!!!!
_________________
Programmiersprachen sind dafür da, um den Computer vor dem Programmierer zu schützen
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Sannaj



Anmeldungsdatum: 19.12.2010
Beiträge: 35

BeitragVerfasst am: 16.10.2011, 11:19    Titel: Antworten mit Zitat

Die Meldung kommt auch nicht vom Compiler, sondern vom Linker (ld). Dieser betrachtet das Problem als nicht fatal und macht einfach weiter. ("skipping" = überspringen). Schau halt ob es Probleme gibt.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Das deutsche QBasic- und FreeBASIC-Forum Foren-Übersicht -> Linux-spezifische Fragen Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.

 Impressum :: Datenschutz